atom feed2 messages in com.googlegroups.beagleboard[beagleboard] BeagleBone error compil...
FromSent OnAttachments
michael hartupJul 20, 2012 5:49 am 
michael hartupJul 24, 2012 2:53 am 
Subject:[beagleboard] BeagleBone error compiling media_build drivers for easycap DC60: "/mach/timer.h" missing
From:michael hartup (
Date:Jul 20, 2012 5:49:22 am


I'm making heavy work of installing the easycap DC60 device on my beaglebone, I thought it might be time ask for some advice.

This device is working using a modified em28xx driver on a raspberry pi, (bear with me) with debian wheezy, and I method I used there was to rebuild the kernel with the em28xx module enabled, which then produced a green output from the capture device. Then I got the latest drivers from, did the ./build thing - then edited height >>= norm_maxh(dev)

to height = norm_maxh(dev) >> 1 in /linux/drivers/media/video/em28xx/em28xx-core.c and then did make, make install in the media_build directory to rebuild my modified driver. This worked.

Now on the Beaglebone I am running Ubuntu-11.10-r11-minimal-armel-2012-07-16. As you would expect - the em28xx module is already there, and producing a green screen.

I want to get the latest drivers and modify em28xx-core.c (I don't believe there is a 'real' patch for this yet), as above.

I have apt-get install linux-headers and have the media_build git repository, and all the dependant packages it tells me i need, but ./build fails with

fatal error: mach/timex.h: No such file or directory, it is looking for
/usr/src/linux-headers-3.2.21-psp16/arch/arm/include/asm/mach/timex.h - there is indeed no /mach/timex.h - I have seen a patch regarding the removal of the #include mach/timex.h within timex.h... but when I tried running that, most of the files it wanted to remove were already gone and I now see an error about mach/io.h, so I don't think that was the thing to do.

I've tried to download the full 3.2.0 kernel source and patch it as I have seen here;!topic/beagleboard/5xMAyFxQbdE

Firstly I'm not exactly sure how to point the media_build make at this source code. Secondly, there isn't a mach/timex.h here either as far as i can see, and timex.h does seem to require it.

Alternatively I tried editing the em28xx driver in the patched linux 3.2.0 source, to no avail, making it, and installing with madprobe, all to no avail.

Any clues?