atom feed15 messages in net.sourceforge.lists.courier-users[courier-users] Odd LDAP-alias issue
FromSent OnAttachments
Sander Holthaus - Orange XLAug 22, 2004 11:11 am 
Sam VarshavchikAug 22, 2004 12:07 pm 
Sander Holthaus - Orange XLAug 22, 2004 12:37 pm 
Robert PfisterAug 22, 2004 8:55 pm 
Jerry AmundsonAug 26, 2004 9:03 am 
Ben KennedyAug 26, 2004 2:08 pm 
Sam VarshavchikAug 26, 2004 3:45 pm 
Georg LutzAug 26, 2004 3:48 pm 
Ben KennedyAug 26, 2004 4:31 pm 
Jacob S. BarrettAug 27, 2004 10:38 am 
Jerry AmundsonAug 27, 2004 11:18 am 
Sam VarshavchikAug 27, 2004 3:36 pm 
Jerry AmundsonAug 28, 2004 8:14 am 
Jerry AmundsonAug 28, 2004 9:37 am 
Ben KennedyAug 30, 2004 7:03 am 
Subject:[courier-users] Odd LDAP-alias issue
From:Sander Holthaus - Orange XL (in@orangexl.com)
Date:Aug 22, 2004 11:11:10 am
List:net.sourceforge.lists.courier-users

I'm having an odd LDAP-alias issue. Aliasses through LDAP work fine, except when they refer to an other alias.

example:

I send a mail to me@domain.com. me@domain.com exists as an LDAP-alias and has an maildrop-attribute of real@domain.com real@domain.com also exists as an LDAP-alias and has as an maildrop attribute me@externalhost.com .

The problem is that mail is rerouted to real@domain.com, but it isn't send to me@externalhost.com . If I send mail to real@domain.com, it's delivered just fine to me@externalhost.com. I almost look like Courier does not recheck the LDAP-Alias database for the newly found maildrop-address.

I find this in the Courier-logfile:

Aug 22 19:55:43 xxxxxxxx courierd: started,id=0000E0F4.4128DE1F.00007D26,from=<xx@xxxxxxx.com>,module=local,h ost=real@domain.com!!9000!9000!!!,addr=real@domain.com ... Aug 22 19:55:43 xxxxxxxx courierlocal: No such file or directory Aug 22 19:55:43 xxxxxxxx courierlocal: id=0000E0F4.4128DE1F.00007D26,from=<xx@xxxxxxx.com>,addr=<reallyme@domain. com>,status: deferred

Kind regards, Sander Holthaus