atom feed57 messages in org.freebsd.freebsd-stableRe: FreeBSD 7.1 Breaks re and rl Netw...
FromSent OnAttachments
Walter VenableJan 7, 2009 6:39 am 
Gavin AtkinsonJan 7, 2009 8:47 am 
Walter VenableJan 7, 2009 10:12 am 
Walter VenableJan 7, 2009 10:45 am 
Walter VenableJan 7, 2009 3:50 pm 
Pyun YongHyeonJan 7, 2009 5:50 pm 
Pyun YongHyeonJan 7, 2009 5:54 pm 
Walter VenableJan 7, 2009 6:20 pm.dmesg
Pyun YongHyeonJan 7, 2009 6:35 pm 
Eugene GladchenkoJan 11, 2009 8:22 am 
Pyun YongHyeonJan 11, 2009 5:11 pm 
eug...@donpac.ruJan 11, 2009 10:32 pm 
Pyun YongHyeonJan 11, 2009 10:41 pm 
Dimitry AndricJan 12, 2009 8:37 am 
Sascha HolzleiterJan 12, 2009 9:20 am 
Walter VenableJan 12, 2009 1:33 pm 
FreeBSDJan 12, 2009 2:11 pm 
Pyun YongHyeonJan 12, 2009 4:40 pm 
Jung-uk KimJan 12, 2009 5:10 pm 
Pyun YongHyeonJan 12, 2009 9:02 pm.diff
Oliver PeterJan 13, 2009 12:59 am 
Pyun YongHyeonJan 13, 2009 1:52 am 
Sascha HolzleiterJan 13, 2009 6:52 am 
FreeBSDJan 13, 2009 7:15 am 
Dimitry AndricJan 13, 2009 7:27 am 
Jung-uk KimJan 13, 2009 3:05 pm 
Pyun YongHyeonJan 13, 2009 4:32 pm 
FreeBSDJan 13, 2009 8:06 pm 
Bartosz StecJan 14, 2009 6:18 am 
Dimitry AndricJan 15, 2009 12:10 pm 
Pyun YongHyeonJan 16, 2009 8:45 pm.diff
Pyun YongHyeonJan 16, 2009 8:47 pm.diff
Pyun YongHyeonJan 16, 2009 8:54 pm.diff
Sascha HolzleiterJan 17, 2009 6:10 am 
Dimitry AndricJan 17, 2009 9:04 am 
Pyun YongHyeonJan 18, 2009 7:26 pm 
Bartosz StecJan 19, 2009 12:31 am 
Pyun YongHyeonJan 19, 2009 12:46 am 
Sascha HolzleiterJan 19, 2009 8:49 am 
Jung-uk KimJan 19, 2009 1:33 pm 
Jung-uk KimJan 19, 2009 3:33 pm 
Pyun YongHyeonJan 19, 2009 6:45 pm 
ian j hartMar 7, 2009 9:17 am 
Pyun YongHyeonMar 7, 2009 6:36 pm.diff
13 later messages
Subject:Re: FreeBSD 7.1 Breaks re and rl Network Interface Drivers
From:Jung-uk Kim (jk@FreeBSD.org)
Date:Jan 12, 2009 5:10:34 pm
List:org.freebsd.freebsd-stable

On Monday 12 January 2009 12:21 pm, Sascha Holzleiter wrote:

Walter Venable wrote:

FreeBSD 7.1 upgrade broke my network access, machine is totally offline (powered-on and I can play inside it at the terminal, but absolutely 0 network access): This happened AFTER make kernel but BEFORE make installworld. I think this implies it's a kernel driver issue.

Hi,

i see similar problems with a re card:

re0@pci0:4:7:0: class=0x020000 card=0x816710ec chip=0x816710ec rev=0x10 hdr=0x00 vendor = 'Realtek Semiconductor' device = 'RTL8169/8110 Family Gigabit Ethernet NIC' class = network subclass = ethernet

After upgrading to 7.1-RELEASE (and also STABLE) the NIC doesn't seem to receive any frames. I can see the DHCP Requests on the DHCP Server but the DHCPOFFERS are never seen by the client with the re0 device. After setting promiscious mode on the interface (i.e. by tcpdump -ni re0) the interface begins to work fine.

I've attached a complete dmesg output, but i think the detection works fine, here the short version:

re0: <RealTek 8169SC/8110SC Single-chip Gigabit Ethernet> port 0x9c00-0x9cff mem 0xdfdff000-0xdfdff0ff irq 20 at device 7.0 on pci4 re0: Chip rev. 0x18000000 re0: MAC rev. 0x00000000 miibus0: <MII bus> on re0 rgephy0: <RTL8169S/8110S/8211B media interface> PHY 1 on miibus0 rgephy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto re0: Ethernet address: 00:1a:92:35:29:fa re0: [FILTER]

Please revert SVN r180519 (or CVS r1.95.2.22) and try again:

http://www.freebsd.org/cgi/cvsweb.cgi/src/sys/dev/re/if_re.c.diff?r1=1.95.2.21;r2=1.95.2.22