atom feed2 messages in com.googlegroups.memcachedRe: new version memcached-1.4.24 and ...
FromSent OnAttachments
Cheng AliNov 26, 2015 7:59 pm 
dormandoNov 26, 2015 10:07 pm 
Subject:Re: new version memcached-1.4.24 and php-pecl-memcached question
From:dormando (dorm@rydia.net)
Date:Nov 26, 2015 10:07:36 pm
List:com.googlegroups.memcached

Hey,

What are your startup arguments for memcached?

In .24 and up the maximum slab count is now 63 instead of 255. if the default number of slab classes is 42, so you'd have to set your scaling factor pretty low to get it to go that high.

Would that cause problems for you?

On Thu, 26 Nov 2015, Cheng Ali wrote:

I have installed memcached ,php-pecl-memcached and libmemcached.

1.memcached (1.4.24) 2.php5.5.30 , php-pecl-memcached (2.2.0) 3.libmemcached(1.0.18)

I try with php script test.php <?php $mc = new Memcached(); $mc->addServer('127.0.0.1',11211); $stats = $mc->getAllKeys(); echo "Return code:", $mc->getResultCode()."\n"; echo "Retucn Message:", $mc->getResultMessage () ."\n"; print_r ($stats); ?> Return code:9 Retucn Message:CLIENT ERROR

I look the log on memcached server log

<36 stats cachedump 57 0 <36 stats cachedump 58 0 <36 stats cachedump 59 0 <36 stats cachedump 60 0 <36 stats cachedump 61 0 <36 stats cachedump 62 0 <36 stats cachedump 63 0

36 CLIENT_ERROR Illegal slab id

<36 quit <36 connection closed.

I change to memcached version 1.4.15 ,and try php script test.php

Return code:0 Retucn Message:SUCCESS Array ( [0] => qinyao [1] => andy )