atom feed8 messages in com.ubuntu.lists.ubuntu-esRe: Error al procesar grub-pc.
FromSent OnAttachments
JuanjoNov 17, 2015 4:37 am 
Braiam PegueroNov 17, 2015 7:46 am 
JuanjoNov 17, 2015 8:55 am 
JuanjoNov 17, 2015 9:28 am 
Braiam PegueroNov 17, 2015 10:51 am 
JuanjoNov 17, 2015 11:28 am 
Braiam PegueroNov 17, 2015 12:34 pm 
JuanjoNov 17, 2015 12:36 pm 
Subject:Re: Error al procesar grub-pc.
From:Juanjo (ubun@gmail.com)
Date:Nov 17, 2015 12:36:10 pm
List:com.ubuntu.lists.ubuntu-es

El 17/11/15 a las 19:51, Braiam Peguero escribió:

Escribe `dpkg -S /etc/grub.d/10_linux` te dara el nombre del paquete, luego escribe `apt-get --reinstall install <nombtre del paquete>` como root para instalar el paquete de nuevo y resolver ambos problemas. On Tue, Nov 17, 2015 at 1:28 PM Juanjo <ubun@gmail.com> wrote:

El 17/11/15 a las 17:55, Juanjo escribió:

El 17/11/15 a las 16:46, Braiam Peguero escribió:

Tienes caracteres extraños en tu /etc/grub.d/10_linux. Revisalo. Por cierto, el aviso sobre el empotrado se resuelve corriendo `sudo dpkg-reconfigure grub-pc` y deseleccionando cualquier cosa que no sea un disco duro, ej: sda, sdb, sdc son discos, sda1, sdc3, sda10 no lo son.

On Tue, Nov 17, 2015 at 8:38 AM Juanjo <ubun@gmail.com <mailto:ubun@gmail.com>> wrote:

Hola a todos cada vez que realizo una actualización o instalo un paquete sale el siguiente error:

Configurando grub-pc (2.02~beta2-9ubuntu1.4) ... Instalando para plataforma i386-pc. Instalación terminada. Ningún error encontrado. Instalando para plataforma i386-pc. grub-install.real: aviso: El sistema de archivos «ext2» no permite el empotrado. grub-install.real: aviso: No es posible empotrar. GRUB solo se puede instalar en esta configuración mediante el uso de listas de bloques. Sin embargo, las listas de bloques no son confiables y su uso no es recomendable.. Instalación terminada. Ningún error encontrado. Generando archivo de configuración grub... Aviso: Ya no se permite establecer GRUB_TIMEOUT a un valor distinto de cero cuando GRUB_HIDDEN_TIMEOUT está activado. /etc/grub.d/10_linux: 1: /etc/grub.d/10_linux: �: not found dpkg: error al procesar el paquete grub-pc (--configure): el subproceso instalado el script post-installation devolvió el código de salida de error 127 E: Sub-process /usr/bin/dpkg returned an error code (1)

Gracias de antemano.

-- Un saludo. Juanjo Linux/GNU - Linux Mint 17.2

-- ubuntu-es mailing list ubun@lists.ubuntu.com <mailto:ubun@lists.ubuntu.com> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

Gracias por responder

Con sudo dpkg-reconfigure grub-pc me da:

/usr/sbin/dpkg-reconfigure: grub-pc está roto o no está totalmente instalado

En cuanto a /etc/grub.d/10_linux: 1: /etc/grub.d/10_linux: �: not found

abriéndolo con vi estan estos caracteres ^@ repetido y al final "/etc/grub.d/10_linux" [Incomplete last line][converted] 1 line, 771 characters -- Un saludo. Juanjo Linux/GNU - Linux Mint 17.2

No se si he hecho bien, pero el problema ya no lo tengo. He instalado grub y eliminado grub-pc además de grub-glxpayload-list y grub2-common,reiniciado el sistema y actualizado y no me da ningún error . Pero el archivo /etc/grub.d/10_linux sigue sin ser legible.

¿He metido la pata?

-- Un saludo. Juanjo Linux/GNU - Linux Mint 17.2

El paquete es grub-common, pero como he comentado antes he eliminado grub-pc, grub2-common y grub-glxplayload-lists e instalado grub, y e problema y no lo tengo (¿creo?) por lo menos no me da ningún error al actualizar desde la terminal. De todas formas he seguido tus indicaciones he reiniciado y sigue sin ser legible el archivo /etc/grub.d/10_linux. Otro problema que le veo (no se si es importante, de ahí mi duda) es las versiones:

grub es la versión: 0.97-29ubuntu66 grub-common es la versión: 2.02~beta2-9ubuntu1.4

Además también tengo instalado grub-pc-bin en su versión 2.02~beta2-9ubuntu1.4 que según la información desde synaptic:

Este paquete contiene una versión de GRUB creada para usar con la arquitectura tradicional PC/BIOS. No instalará automáticamente GRUB como gestor de arranque activo, ni lo actualizará desde grub.cfg, así que debería instalar grub-pc en su lugar.

Resumiendo, lo dejo como esta con grub y grub-common o eliminio grub-pc-bin e instalo grub-pc y grub2-common

SOLUCIONADO He eliminado desinstalado completamente (desde synaptic) grub, grub-pc-bin, grub-common y se ha añadido lupin-support. Después he instalado desde la terminal grub2 (grub-glxpayload-lists, grub-pc, grub2-common, grub-common, grub2 y grub-pc-bin) , tambien lupin-support (por si acaso) reinicio, todo bien salvo que no se ve el logo de la distribución o como lo tenia antes los procesos de inicio. Creo que esta solucionado, gracias Braiam, ya he aprendido otras ordenas más.