atom feed11 messages in org.osafoundation.chandler-devRe: [chandler-dev] Building Chandler ...
FromSent OnAttachments
Matt SchaferJun 18, 2009 10:20 pm 
Grant BaillieJun 19, 2009 8:06 am 
Matt SchaferJun 21, 2009 3:45 pm 
Grant BaillieJun 24, 2009 4:44 pm 
Matt SchaferJun 25, 2009 12:41 am 
Grant BaillieJun 25, 2009 11:41 am 
Matt SchaferJun 25, 2009 2:07 pm 
Grant BaillieJun 26, 2009 4:46 pm 
Andi VajdaJun 26, 2009 5:02 pm 
Grant BaillieJun 26, 2009 5:58 pm 
Andi VajdaJun 27, 2009 12:21 am 
Subject:Re: [chandler-dev] Building Chandler 1.0.3+ on Ubuntu 9.04 (Jaunty)
From:Grant Baillie (
Date:Jun 24, 2009 4:44:57 pm

On 21 Jun, 2009, at 15:45, Matt Schafer wrote:

Hi Grant,

Thanks for your help. I was able to successfully build the .deb for Jaunty using rev 16688. I used the packaging directory in the sandbox repository with the instructions you quoted.

I tweaked both the debian/changelog file and the debian/control file. An svn diff is at the end of this email. Took me a little bit to get the control file right. I got the Build-Depends fixed up, but then when I tried to install the package, it wanted to install an old version of vobject, because I failed to remove it from the Depends line.

The diff can be hard to follow, so here is a summary of the changes to Build-Depends and Depends:

Build-Depends: 1) Change python-dev (>=2.5) to python2.6-dev 2) Delete python-vobject 3) Add python-twisted (>=8.2.0), fakeroot and svn-buildpackage

Depends: 1) Change python (>=2.5) to python2.6 2) Delete python-vobject 3) Add python-twisted(>=8.2.0)

One other thing I noticed. The openjdk-6-* packages in Build- Depends and Depends require a version >=0.6b11. But the packages in the Ubuntu repository for Jaunty are version 6b14-1.4.1-0ubuntu7. It looks like the control file is looking for 0.6 or later, and the packages are 6 or later. This would make all packages satisfy the version requirement, even if they're older than 6b11. Not sure this is what we want.

Also couldn't figure out how to get the version string in Chandler (splash screen and Help>About) to reflect the built version. Since r16688 has, that's what it displays. Though after installation, I manually changed to 1.0.3+svn-r16688. I'm not too worried about it, since I'll be the only one using this package. Unless other folks would like it, too.

Bottom line: I now have a Chandler 1.0.3 that works in Jaunty without the error and deprecation warnings. Life is better now.

Hi, Matt

Good job on getting the deb built! A couple of questions, comments, and answers to your questions:

1) Are the python --> python2.6 changes required (or recommended)? I ask because we use that control file to build on Hardy, Intrepid and Jaunty, and so there would have to be a branch in svn if the dependencies were different on the 3 platforms.

2) I'm not an expert on packaging, so I'm not sure if the fakeroot and svn-buildpackage dependencies are required. They are needed for creating .debs, but probably there are other ways of building/ extracting packages?

3) You're right about the openjdk-6-* dependencies: I guess we were setting the bar lower than we thought :P.

4) Yes, the file doesn't pick up the svn version automatically (it's tweaked by hand when creating new svn branches for builds). There is currently code to figure out the version from the .svn directory (if one is present); maybe there's a way to do the same thing for a file installed of a debian package.


Open Source Applications Foundation "chandler-dev" mailing list