atom feed3 messages in com.ubuntu.lists.ubuntu-auRe: Internet Connection
FromSent OnAttachments
DeanOct 26, 2007 3:16 pm 
Rapael MorchaOct 26, 2007 10:24 pm 
Rapael MorchaOct 27, 2007 12:31 am 
Subject:Re: Internet Connection
From:Rapael Morcha (raph@gmail.com)
Date:Oct 27, 2007 12:31:15 am
List:com.ubuntu.lists.ubuntu-au

On Sat, Oct 27, 2007 at 04:14:16PM +1000, Kevan Fitzakerley wrote:

Hi

Yes I to lost internet connection after upgrading to 7.10.

What I did to fix (sort of ) I reinstalled 7.04 and then installed KDE desktop, then from KDE I did another upgrade to 7.10. After the upgrade I could not get internet connection using FireFox but I could using Konqueror.

Hi Kevan,

As I said check your /etc/resolv.conf. I believe most of the applications
accessing internet should honour it.

Also make sure your dhclient.conf file ($ find /etc/ -name "dhclient.conf") has
these entries -

----- #need this next line with your ISP's Primary and Secondary DNS prepend domain-name-servers x.x.x.x, x.x.x.x;

#if it already has this entry, leave it as it is. Otherwise, put 'em. request subnet-mask, broadcast-address, time-offset, routers, domain-name, domain-name-servers, host-name, netbios-name-servers, netbios-scope;

----

These files get overwritten everytime when you execute - $ dhclient eth0; to get dynamic IP from your router.

Also sometimes, new driver for your specific network card (wireless, wired) get
loaded in the new distribution. In that case, if it doesn't work, you need to
replace the new driver with the old one (usually located in /lib/modules/`uname
-r`). This symptom is apparent when you can't get your interface (eth0/1/2
etc..) to work.