On Wed, 31 May 2006 00:11:23 +0200, Jonas Sicking <jon...@sicking.cc> wrote:
I'm not in love with having "match" in the name, but I could live
with matchAll() and matchOne().
I like these names. Having short names is nice and all, but having
clear ones is even better. Especially when the extra cost is just
another three letters to type.
I'm not really fond of matchOne()... Is there any precedence on this?
Don't know. But i'm not sure there is any precedence of having the
un-postfixed method (in this case 'match') just return the first entry
either. Usually the base method returns the full result and there are
prefixed/postfixed methods that just return part of it.