atom feed2 messages in com.ubuntu.lists.ubuntu-bugs[Bug 1081479] [NEW] --working-directo...
FromSent OnAttachments
Sergio RubioNov 21, 2012 12:06 am 
Launchpad Bug TrackerSep 28, 2013 4:28 am 
Subject:[Bug 1081479] [NEW] --working-directory option doesn't work with xfce4-terminal.wrapper
From:Sergio Rubio (rubi@frameos.org)
Date:Nov 21, 2012 12:06:24 am
List:com.ubuntu.lists.ubuntu-bugs

Public bug reported:

"xfce4-terminal.wrapper --working-directory=/tmp" does not set the working directory when launching the terminal.

"xfce4-terminal --working-directory=/tmp" works however.

x-terminal-emulator is set to xfce4-terminal.wrapper by default in Xubuntu, so that's broken too:

[9861][rubiojr.napoleon] sudo update-alternatives --config x-terminal- emulator

  Selection Path Priority Status

------------------------------------------------------------ * 0 /usr/bin/xfce4-terminal.wrapper 40 auto mode   1 /usr/bin/koi8rxterm 20 manual mode   2 /usr/bin/lxterm 30 manual mode   3 /usr/bin/uxterm 20 manual mode   4 /usr/bin/xfce4-terminal.wrapper 40 manual mode   5 /usr/bin/xterm 20 manual mode

Press enter to keep the current choice[*], or type selection number:

ProblemType: Bug DistroRelease: Ubuntu 12.10 Package: xfce4-terminal 0.4.8-1ubuntu3 ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7 Uname: Linux 3.5.0-18-generic x86_64 ApportVersion: 2.6.1-0ubuntu6 Architecture: amd64 Date: Wed Nov 21 08:59:24 2012 InstallationDate: Installed on 2012-10-29 (22 days ago) InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5) MarkForUpload: True SourcePackage: xfce4-terminal UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: xfce4-terminal (Ubuntu) Importance: Undecided Status: New

** Tags: amd64 apport-bug quantal third-party-packages

** Description changed:

"xfce4-terminal.wrapper --working-directory=/tmp" does not set the - working when launching the terminal. + working directory when launching the terminal.

"xfce4-terminal --working-directory=/tmp" works however.

x-terminal-emulator is set to xfce4-terminal.wrapper by default in Xubuntu, so that's broken too:

[9861][rubiojr.napoleon] sudo update-alternatives --config x-terminal- emulator

- Selection Path Priority Status +   Selection Path Priority Status ------------------------------------------------------------ * 0 /usr/bin/xfce4-terminal.wrapper 40 auto mode - 1 /usr/bin/koi8rxterm 20 manual mode - 2 /usr/bin/lxterm 30 manual mode - 3 /usr/bin/uxterm 20 manual mode - 4 /usr/bin/xfce4-terminal.wrapper 40 manual mode - 5 /usr/bin/xterm 20 manual mode +   1 /usr/bin/koi8rxterm 20 manual mode +   2 /usr/bin/lxterm 30 manual mode +   3 /usr/bin/uxterm 20 manual mode +   4 /usr/bin/xfce4-terminal.wrapper 40 manual mode +   5 /usr/bin/xterm 20 manual mode

Press enter to keep the current choice[*], or type selection number:

ProblemType: Bug DistroRelease: Ubuntu 12.10 Package: xfce4-terminal 0.4.8-1ubuntu3 ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7 Uname: Linux 3.5.0-18-generic x86_64 ApportVersion: 2.6.1-0ubuntu6 Architecture: amd64 Date: Wed Nov 21 08:59:24 2012 InstallationDate: Installed on 2012-10-29 (22 days ago) InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5) MarkForUpload: True SourcePackage: xfce4-terminal UpgradeStatus: No upgrade log present (probably fresh install)

-- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. https://bugs.launchpad.net/bugs/1081479

Title: --working-directory option doesn't work with xfce4-terminal.wrapper

To manage notifications about this bug go to: https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/1081479/+subscriptions