atom feed1 message in org.codehaus.izpack.user[izpack-user] Getting a problem with ...
FromSent OnAttachments
Sateesh varmaMay 1, 2008 8:49 am 
Subject:[izpack-user] Getting a problem with IzPack web installer.
From:Sateesh varma (
Date:May 1, 2008 8:49:58 am

Hi All,

I have created one web installer using Izpack-3.11.0.

For this I have created webinstall.xml.

<?xml version="1.0" encoding="iso-8859-1" standalone="yes" ?>

<installation version="1.0">

<info> <appname>Sample Installation</appname> <appversion>1.4 beta 666</appversion> <authors> <author name="JPz" email=""/> <author name="Hidden Man" email=""/> </authors> <url>http://localhost:8080/</url> <webdir>http://localhost:8080/webappl</webdir> </info>

<guiprefs width="640" height="480" resizable="no"/>

<locale> <langpack iso3="eng"/> <langpack iso3="fra"/> </locale>

<resources> <res id="LicencePanel.licence" src="Licence.txt"/> <res id="" src="Readme.txt"/> <res id="WebInstallers.url" src="installer.txt"/> </resources>

<panels> <panel classname="HelloPanel"/> <panel classname="InfoPanel"/> <panel classname="LicencePanel"/> <panel classname="TargetPanel"/> <panel classname="PacksPanel"/> <panel classname="InstallPanel"/> <panel classname="FinishPanel"/> </panels>

<packs> <pack name="Base" required="no"> <description>The base files</description> <file src="Readme.txt" targetdir="$INSTALL_PATH"/> <file src="Licence.txt" targetdir="$INSTALL_PATH"/> <file src="script.bat" targetdir="$INSTALL_PATH"/> <parsable targetfile="$INSTALL_PATH/script.bat"/> <!-- The file will be parsed --> </pack> <pack name="Docs" required="no"> <description>The documentation</description> <file src="doc" targetdir="$INSTALL_PATH"/> <!-- Reccursive adding --> </pack> <pack name="Sources" required="no"> <description>The sources</description> <file src="src" targetdir="$INSTALL_PATH"/> </pack> </packs>


When I compiled a webinstaller.xml file using the command "compile webinstall.xml -b . -o .\webinstaller.jar -k web" , I got 4 jar files with the name webinstaller.jar,remaining 3 are webinstaller.pack-Base.jar, webinstaller.pack-Docs.jar,webinstaller.pack-Source.jar.and one xml file i.e., packsinfo.xml.

I have placed 4 jar files in webserver(tomcat) i.e, http://localhost:8080/webappl.

I have created a jsp page to download the webinstaller.jar file .

When I am downloading and clicking on the webinstaller.jar , It's working upto package panel and its not installing the packages(its getting strucked at installation panel).

Individually when i am clicking on th 3 pack jar files, one window is displaying that they are corrupted.

Could anyone help me ,please? Thanks in advance.

-- View this message in context: Sent from the izpack - users @ codehaus mailing list archive at

--------------------------------------------------------------------- To unsubscribe from this list, please visit: