atom feed24 messages in net.php.lists.phpdoc[PHP-DOC] A blank page shows when bro...
FromSent OnAttachments
HaohappyDec 21, 2008 7:47 pm 
Gang ChenDec 21, 2008 10:57 pm 
Hannes MagnussonDec 22, 2008 12:47 am 
HaohappyDec 22, 2008 6:31 pm 
Philip OlsonDec 22, 2008 8:29 pm 
Daniel ConvissorDec 23, 2008 12:45 pm 
Hannes MagnussonDec 23, 2008 2:09 pm 
G. T. Stresen-ReuterDec 23, 2008 2:20 pm 
Hannes MagnussonDec 23, 2008 2:28 pm 
Christian WeiskeDec 23, 2008 5:39 pm 
Daniel ConvissorDec 23, 2008 8:25 pm 
Hannes MagnussonDec 24, 2008 4:48 am 
G. T. Stresen-ReuterDec 24, 2008 7:32 am 
Christian WeiskeDec 24, 2008 7:45 am 
Hannes MagnussonDec 24, 2008 8:20 am 
Keryx WebDec 25, 2008 4:00 am 
Hannes MagnussonDec 25, 2008 3:01 pm 
Christian WeiskeDec 26, 2008 1:36 am 
Keryx WebDec 26, 2008 3:38 pm 
Hannes MagnussonDec 26, 2008 5:15 pm 
Keryx WebDec 30, 2008 11:55 am 
Hannes MagnussonDec 30, 2008 12:01 pm 
Keryx WebJan 7, 2009 1:13 pm 
Hannes MagnussonJan 7, 2009 1:47 pm 
Subject:[PHP-DOC] A blank page shows when browsing some doc files in MS IE
From:Haohappy (haoh@gmail.com)
Date:Dec 21, 2008 7:47:11 pm
List:net.php.lists.phpdoc

Hello,

I used the PhD to generate html docs, but I got a blank page when I browsed some pages in Microsoft IE. It seemed the IE can't recognize the UTF-8 charset. So I look into the source of the html file:

<title>类与对象(PHP 4)</title> <meta http-equiv="content-type" content="text/html; charset=UTF-8">

These two lines of code work well in Firefox, Safari. But in IE, it should be changed to:

<meta http-equiv="content-type" content="text/html; charset=UTF-8"> <title>类与对象(PHP 4)</title>

We need to put the <meta> before <title>, or the IE may not be able to recognize the right charset.

Is there anyone help me resolve this problem? I don't know where is the 'template' of our PHP-doc files.

The commands I used: php configure.php --with-lang=zh --enable-chm /home/www/php/bin/phd -d .manual.xml -L zh

The html files were generated in the directory 'phpdoc-zh/chm/res' .

Thanks in advance.