atom feed10 messages in net.sourceforge.lists.courier-imapRe: [Courier-imap] Problems migrating...
FromSent OnAttachments
David J. GreenbergerFeb 24, 2006 9:38 am 
Jay LeeFeb 24, 2006 9:43 am 
David J. GreenbergerFeb 24, 2006 9:51 am 
jl...@pbu.eduFeb 24, 2006 10:01 am 
David J. GreenbergerFeb 24, 2006 10:10 am 
Sam VarshavchikFeb 24, 2006 3:39 pm 
Brian CandlerFeb 25, 2006 12:58 am 
David J. GreenbergerFeb 25, 2006 6:04 pm 
Brian CandlerFeb 26, 2006 12:14 am 
David J. GreenbergerFeb 26, 2006 3:18 am 
Subject:Re: [Courier-imap] Problems migrating to a new system
From:David J. Greenberger (gree@gmail.com)
Date:Feb 24, 2006 10:10:48 am
List:net.sourceforge.lists.courier-imap

On 2/24/06, jl@pbu.edu <jl@pbu.edu> wrote:

On Fri, February 24, 2006 12:51 pm, David J. Greenberger wrote:

There should be subfolders under Mailing lists, but they're not showing up:

Not in the Maildir there shouldn't be. All of your folders and subfolders (and subfolders of subfolders) in IMAP are still at one level in the Maildir so that if my IMAP folder structure looks like:

INBOX Sent 2005 Jan-July Aug-Dec

my Maildir structure should look like:

#ls -al $HOME\Maildir\ -rw-r--r-- 1 vmail vmail 2329 Feb 23 11:29 courierimapsubscribed -rw-r--r-- 1 vmail vmail 149097 Feb 24 11:18 courierimapuiddb -rw-r--r-- 1 vmail vmail 134224 Nov 26 20:30 courierpop3dsizelist drwx------ 2 vmail vmail 12288 Feb 24 11:18 new drwx------ 2 vmail vmail 4096 Feb 24 12:56 tmp drwx------ 2 vmail vmail 262144 Feb 24 11:19 cur drwx------ 6 vmail vmail 4096 Mar 9 2005 .Sent drwx------ 6 vmail vmail 4096 Sep 5 2004 .Sent.2005 drwx------ 6 vmail vmail 4096 Sep 5 2004 .Sent.2005.Jan-July drwx------ 6 vmail vmail 4096 Sep 5 2004 .Sent.2005.Aug-Dec

See how Jan-July and Aug-Dec are still directories underneath the Maildir directory even though in the IMAP structure they are underneath 2005?

Gotcha, but they're not showing up there either!

Anyways, I think you borked something with your copying over... What command did you use? Your subfolders of "Mailing Lists" should appear when you do a ls -al in Maildir if they got copied over at all. If they didn't get copied but still were listed in courierimapsubscribed then you'd get an error similar to what you're reporting...

I just used a simple cp -r from the old location to the new. That should have done the trick, no?

I'm tempted to give it another shot, but is there any way to hold onto the messages that have come in since this new installation started working? (It's not critical, but it would be nice.)

Thanks again.

David