atom feed6 messages in com.redhat.kickstart-listStupid dependencies.. ?
FromSent OnAttachments
Hajducko, StevenMar 13, 2008 1:31 pm 
Michael DeHaanMar 13, 2008 1:41 pm 
Hajducko, StevenMar 13, 2008 1:51 pm 
John SummerfieldMar 14, 2008 2:02 am 
Hajducko, StevenMar 14, 2008 1:53 pm 
John SummerfieldMar 14, 2008 4:49 pm 
Subject:Stupid dependencies.. ?
From:Hajducko, Steven (stev@digitalinsight.com)
Date:Mar 13, 2008 1:31:21 pm
List:com.redhat.kickstart-list

Is there a place to suggest better dependencies for future builds of RH? I'm not sure which list / bug tracking system I should be putting this into.

For example,

the core group lists authconfig as a mandatory package.

authconfig requires rhpl, a package that contains python code used by other programs.

rhpl requires wireless-tools.

It was not this way in RH4. authconfig was part of core, but the RHPL package was not required by it, nor did the RHPL package require wireless-tools.

So in essence, every server I install into my datacenter with RH5 is going to have the wireless-tools package, a completely arbitrary and unnecessary package, unless I uninstall authconfig, rhpl and wireless-tools in the %post.

..................................................................... Steven Hajducko Systems Engineer, Systems Integration w: 818.597.6443 m: 805.377.9074