atom feed3 messages in org.rubyonrails.railsproblem with "gem update mysql"
FromSent OnAttachments
Herbert Groot JebbinkOct 22, 2005 2:12 am 
Chris BooneOct 22, 2005 7:37 am 
Herbert Groot JebbinkOct 22, 2005 7:56 am 
Subject:problem with "gem update mysql"
From:Herbert Groot Jebbink (herb@public.gmane.org)
Date:Oct 22, 2005 2:12:25 am
List:org.rubyonrails.rails

Hi,

I have activated scaffold in my first rails application ( following http://manuals.rubyonrails.com/read/chapter/38 ) and now I get the next error

'Packets out of order' error was received from the database. Please update your mysql bindings (gem update mysql) and read http://dev.mysql.com/doc/mysql/en/password-hashing.html for more information.

if I run the "gem update mysql" command I get the next error.

Upgrading installed gems... Attempting remote upgrade of mysql Attempting remote installation of 'mysql' Building native extensions. This could take a while... ERROR: While executing gem ... (RuntimeError) ERROR: Failed to build gem native extension. Gem files will remain installed in /usr/local/lib/ruby/gems/1.8/gems/mysql-2.6 for inspection. ruby extconf.rb update mysql\nchecking for mysql_query() in -lmysqlclient... no checking for main() in -lm... yes checking for mysql_query() in -lmysqlclient... no checking for main() in -lz... yes checking for mysql_query() in -lmysqlclient... no checking for main() in -lsocket... no checking for mysql_query() in -lmysqlclient... no checking for main() in -lnsl... yes checking for mysql_query() in -lmysqlclient... no

How can I fix this ?

Kind Regards, Herbert