I do not like the new syntax at all. If anything it seems rather unnatural and
what do you save, typing of 5 characters that makes it clear that this is an
array to even the most novice of users? It certainly not going to make the
code any faster and if anything will only add confusion.
There's enough magic already..I could say +1 if magic_quotes_*
is removed and everything is made case-sensitive first. :)