atom feed11 messages in org.osafoundation.chandler-devRe: [chandler-dev] Building Chandler ...
FromSent OnAttachments
Matt SchaferJun 18, 2009 10:19 pm 
Grant BaillieJun 19, 2009 8:05 am 
Matt SchaferJun 21, 2009 3:44 pm 
Grant BaillieJun 24, 2009 4:44 pm 
Matt SchaferJun 25, 2009 12:41 am 
Grant BaillieJun 25, 2009 11:41 am 
Matt SchaferJun 25, 2009 2:06 pm 
Grant BaillieJun 26, 2009 4:45 pm 
Andi VajdaJun 26, 2009 5:01 pm 
Grant BaillieJun 26, 2009 5:58 pm 
Andi VajdaJun 27, 2009 12:21 am 
Subject:Re: [chandler-dev] Building Chandler 1.0.3+ on Ubuntu 9.04 (Jaunty)
From:Matt Schafer (slyy@gmail.com)
Date:Jun 21, 2009 3:44:56 pm
List:org.osafoundation.chandler-dev

Hi Grant,

Thanks for your help. I was able to successfully build the .deb for Jaunty using rev 16688. I used the packaging directory in the sandbox repository with the instructions you quoted.

I tweaked both the debian/changelog file and the debian/control file. An svn diff is at the end of this email. Took me a little bit to get the control file right. I got the Build-Depends fixed up, but then when I tried to install the package, it wanted to install an old version of vobject, because I failed to remove it from the Depends line.

The diff can be hard to follow, so here is a summary of the changes to Build-Depends and Depends:

Build-Depends: 1) Change python-dev (>=2.5) to python2.6-dev 2) Delete python-vobject 3) Add python-twisted (>=8.2.0), fakeroot and svn-buildpackage

Depends: 1) Change python (>=2.5) to python2.6 2) Delete python-vobject 3) Add python-twisted(>=8.2.0)

One other thing I noticed. The openjdk-6-* packages in Build-Depends and Depends require a version >=0.6b11. But the packages in the Ubuntu repository for Jaunty are version 6b14-1.4.1-0ubuntu7. It looks like the control file is looking for 0.6 or later, and the packages are 6 or later. This would make all packages satisfy the version requirement, even if they're older than 6b11. Not sure this is what we want.

Also couldn't figure out how to get the version string in Chandler (splash screen and Help>About) to reflect the built version. Since r16688 has 1.0.4.dev, that's what it displays. Though after installation, I manually changed version.py to 1.0.3+svn-r16688. I'm not too worried about it, since I'll be the only one using this package. Unless other folks would like it, too.

Bottom line: I now have a Chandler 1.0.3 that works in Jaunty without the error and deprecation warnings. Life is better now.

Matt

svn diff of checked-out sandbox/packaging/deb/chandler/trunk:

Index: debian/control =================================================================== --- debian/control (revision 1977) +++ debian/control (working copy) @@ -2,16 +2,16 @@ Section: mail Priority: optional Maintainer: OSAF buildmasters <buil@osafoundation.org> -Uploaders: Jared Rhine <jar@wordzoo.com> +Uploaders: Jared Rhine <jar@wordzoo.com>, Matt Schafer < slyy@gmail.com> Standards-Version: 3.8.0 -Build-Depends: debhelper (>=7), build-essential, curl, subversion, python-dev (>= 2.5), gcc (>=4.2), gettext, patch, libgtk2.0-dev, libsdl1.2-dev, openjdk-6-jre-headless (>=0.6b11), openjdk-6-jdk (>=0.6b11), ant, python-setuptools (>= 0.6c6), python-m2crypto (>= 0.18.2), python-configobj (>= 4.3.2), python-zopeinterface (>= 3.3.1), python-pyicu, python-dateutil, python-vobject, python-epydoc, python-docutils (>=0.4), pylint, python-parsedatetime, imagemagick, inkscape, quilt +Build-Depends: debhelper (>=7), build-essential, curl, subversion, python2.6-dev, gcc (>=4.2), gettext, patch, libgtk2.0-dev, libsdl1.2-dev, openjdk-6-jre-headless (>=0.6b11), openjdk-6-jdk (>=0.6b11), ant, python-setuptools (>= 0.6c6), python-m2crypto (>= 0.18.2), python-configobj (>= 4.3.2), python-zopeinterface (>= 3.3.1), python-pyicu, python-dateutil, python-epydoc, python-docutils (>=0.4), pylint, python-parsedatetime, imagemagick, inkscape, quilt, python-twisted (>=8.2.0), fakeroot, svn-buildpackage Homepage: http://chandlerproject.org/ Vcs-Svn: http://svn.osafoundation.org/chandler/trunk/ Vcs-Browser: http://svn.osafoundation.org/viewvc/chandler/trunk/

Package: chandler Architecture: any -Depends: libsdl1.2debian (>= 1.2.9), libgtk2.0-0 (>= 2.10), openjdk-6-jre (>=0.6b11), python-m2crypto (>= 0.18.2), bzip2 (>= 1.0.3), python (>= 2.5), python-setuptools (>= 0.6c6), python-configobj (>= 4.3.2), python-zopeinterface (>= 3.3.1), python-pyicu, python-dateutil, python-vobject, python-parsedatetime, libc6 +Depends: libsdl1.2debian (>= 1.2.9), libgtk2.0-0 (>= 2.10), openjdk-6-jre (>=0.6b11), python-m2crypto (>= 0.18.2), bzip2 (>= 1.0.3), python2.6, python-setuptools (>= 0.6c6), python-configobj (>= 4.3.2), python-zopeinterface (>= 3.3.1), python-pyicu, python-dateutil, python-parsedatetime, libc6, python-twisted (>= 8.2.0) Description: Manage and share events, calendars, and notes with a desktop application Described as a "Note-to-Self Organizer", Chandler Desktop provides a unique way to track calendars, tasks, and notes, each placed into one Index: debian/changelog =================================================================== --- debian/changelog (revision 1977) +++ debian/changelog (working copy) @@ -1,3 +1,12 @@ +chandler (1.0.3.1~svn16688-1) unstable; urgency=low + + * Bugs fixed in this release (tracker @ http://bugzilla.osafoundation.org ): + - Bug#12792 Chandler does not work under Ubuntu 9.04 Jaunty + - Bug#12802 Italian translation missing in 1.0.3 + - Bug#11059 Upgrade twisted to 8.2.0 + + -- Matt Schafer <slyy@gmail.com> Sun, 21 Jun 2009 11:03:22 -0700 + chandler (1.0.3-1) unstable; urgency=low

* Bugs fixed in this release (tracker @ http://bugzilla.osafoundation.org ):

On Fri, Jun 19, 2009 at 8:06 AM, Grant Baillie <gra@osafoundation.org>wrote:

BTW, the debs we roll out for chandler 1.0.x releases are made using:

http://svn.osafoundation.org/sandbox/packaging/deb/chandler/trunk

which wraps the svn checkout & make procedure you were going through. Instructions for that are at:

http://svn.osafoundation.org/sandbox/packaging/deb/HOWTO.txt

HTH,

--Grant

Open Source Applications Foundation "chandler-dev" mailing list http://lists.osafoundation.org/mailman/listinfo/chandler-dev