atom feed52 messages in org.apache.incubator.cloudstack-devRe: Swift in 4.2 is broken, anybody w...
FromSent OnAttachments
Edison SuJul 3, 2013 2:29 pm 
Angeline ShenJul 3, 2013 2:56 pm 
Prasanna SanthanamJul 3, 2013 9:27 pm 
David NalleyJul 8, 2013 6:21 am 
Chip ChildersJul 8, 2013 6:39 am 
Chip ChildersJul 8, 2013 6:45 am 
Edison SuJul 8, 2013 10:13 am 
Chip ChildersJul 8, 2013 10:24 am 
Chip ChildersJul 8, 2013 1:26 pm 
John BurwellJul 8, 2013 1:41 pm 
Chip ChildersJul 8, 2013 1:49 pm 
Animesh ChaturvediJul 8, 2013 3:11 pm 
Edison SuJul 8, 2013 3:29 pm 
Edison SuJul 8, 2013 4:34 pm 
John BurwellJul 9, 2013 7:53 am 
Edison SuJul 9, 2013 10:56 am 
Chip ChildersJul 9, 2013 10:59 am 
Edison SuJul 9, 2013 11:00 am 
Chip ChildersJul 9, 2013 11:08 am 
Edison SuJul 9, 2013 11:11 am 
Chip ChildersJul 9, 2013 11:21 am 
Edison SuJul 9, 2013 11:54 am 
Chip ChildersJul 9, 2013 11:56 am 
John BurwellJul 9, 2013 12:56 pm 
Sebastien GoasguenJul 9, 2013 1:06 pm 
Chip ChildersJul 9, 2013 1:09 pm 
Edison SuJul 9, 2013 1:13 pm 
Edison SuJul 9, 2013 1:56 pm 
John BurwellJul 9, 2013 2:02 pm 
Mathias MullinsJul 9, 2013 5:22 pm 
Animesh ChaturvediJul 9, 2013 11:45 pm 
Mathias MullinsJul 10, 2013 8:49 am 
Caleb CallJul 10, 2013 8:52 am 
Joe BrockmeierJul 10, 2013 10:46 am 
Edison SuJul 10, 2013 11:12 am 
Mike TutkowskiJul 10, 2013 11:18 am 
16 later messages
Subject:Re: Swift in 4.2 is broken, anybody wants it to be supported in 4.2?
From:Chip Childers (chip@sungard.com)
Date:Jul 8, 2013 1:49:02 pm
List:org.apache.incubator.cloudstack-dev

On Mon, Jul 08, 2013 at 09:22:07AM -0400, David Nalley wrote:

On Wed, Jul 3, 2013 at 5:29 PM, Edison Su <Edis@citrix.com> wrote:

Due to object store refactor, Swift is broken. The reason, is that, we only have
S3 test environment in our lab, so only S3 is tested for now. Before adding the feature back, I'd better ask from, the community, do we want
to support Swift? If so, which version of Swift? This will take some efforts to
support Swift, are there any volunteers can help the integration?

Whats the bug ID for this?

I have opened https://issues.apache.org/jira/browse/CLOUDSTACK-3400 as a blocker for 4.2.

Unplanned/Unannounced deprecation of a feature is a blocker IMO. It engenders a bad relationship with our users, and strands them on previous versions with no good migration/upgrade path.