atom feed7 messages in com.googlegroups.memcachedRe: what is a connection refused(111)...
FromSent OnAttachments
pedalpeteSep 5, 2008 11:46 am 
Steve YenSep 5, 2008 1:01 pm 
pedalpeteSep 5, 2008 1:54 pm 
Jehiah CzebotarSep 5, 2008 2:51 pm 
dormandoSep 5, 2008 3:00 pm 
pedalpeteSep 5, 2008 3:00 pm 
pedalpeteSep 5, 2008 3:04 pm 
Subject:Re: what is a connection refused(111) error?
From:dormando (dorm@rydia.net)
Date:Sep 5, 2008 3:00:14 pm
List:com.googlegroups.memcached

Hey,

When you're getting started with memcached, it might be a good idea to start it without the -d option the first time. We daemonize really early (maybe this is fixable...) so a startup error isn't always printed when you use -d.

By removing the daemonize option it'll run in the foreground. So you can see why it doesn't start, but you'll have to remember to restart it with -d once you're sure it works.

On Fri, 5 Sep 2008, pedalpete wrote:

Thanks Steve,

I am kinda new to admining my own server, so no, I hadn't tried telnet. And you are correct, I can't telnet to 11211. But at the same time, I can't be sure that memcached is running either. I'm not sure how to test for that. I have started memcached with [code] memcached -d -m 1024 -l 10.0.0.40 -p 11211 -u nobody [/code]

and I get returned to the command line. it doesn't say if it is actually running or not, but I assumed without errors that it was running.

when I look through ps aux | less, I don't see an entry for Memcache, so I'm guessing that maybe memcache isn't running? or would it not show up in running processes?

Sorry I'm at a bit of a loss here, I'm surprised memcached doesn't return an error if it can't start or something.

On Sep 5, 1:01 pm, "Steve Yen" <stev@gmail.com> wrote:

Could be any number of things...

111 is just the ECONNREFUSED error code value from underlying socket connect() syscall.

Apologies if you've tried or thought of these top-of-head ideas already... a - is memcached really running?  on port 11211? b - can you telnet to it?  can you telnet as the same user as your websvr/php, on the same box? c - if a is yes and b is no, you might have weird firewall rules?

On Fri, Sep 5, 2008 at 11:47 AM, pedalpete <p.@hearwhere.com> wrote:

I've tried reinstalling memcache a few times, and I can connect to it from root, but when attempting to connect via my php page, I get a [code] Memcache::connect() [memcache.connect]: Server 127.0.0.1 (tcp 11211) failed with: Connection refused (111) [/code]

I have tried using 'localhost' as the server which works on my dev machine, but not on testing or prod.

I can't seem to find what this error means. Anybody know?