atom feed28 messages in org.xwiki.users[xwiki-users] problem with Chinese
FromSent OnAttachments
ning wangMar 16, 2007 7:32 am.html
Sergiu DumitriuMar 16, 2007 8:00 am.htm, .sql
Vincent MassolMar 16, 2007 8:24 am.htm
ning wangMar 16, 2007 8:27 am.html
Sergiu DumitriuMar 16, 2007 8:42 am.htm
Vincent MassolMar 16, 2007 8:44 am.html
ning wangMar 16, 2007 9:10 am.htm
ning wangMar 16, 2007 9:12 am.html
Gilles SerassetMar 16, 2007 9:24 am.htm
Sergiu DumitriuMar 16, 2007 9:30 am.html
Sergiu DumitriuMar 16, 2007 10:03 am.htm
jimmy at comkraft.comMar 16, 2007 10:12 am 
ning wangMar 16, 2007 10:17 am.html
Gilles SerassetMar 16, 2007 10:18 am.html
ning wangMar 16, 2007 10:38 am.htm
ning wangMar 16, 2007 11:27 am.html
ning wangMar 19, 2007 9:32 am.html
beyMar 19, 2007 12:28 pm.htm
Youcef BEYMar 19, 2007 4:23 pm.html
Jackson WangMar 20, 2007 7:55 pm.htm, .properties, .png
ning wangMar 20, 2007 8:03 pm.html
Vincent MassolMar 21, 2007 12:08 am.htm
Sergiu DumitriuMar 21, 2007 7:27 am.html
ning wangMar 21, 2007 10:15 am.htm
Sergiu DumitriuMar 21, 2007 10:25 am.htm
Jackson WangMar 22, 2007 2:36 am.html
ning wangMar 22, 2007 8:38 am.htm, .jpg
ning wangMar 22, 2007 8:51 am.htm
Subject:[xwiki-users] problem with Chinese
From:ning wang (dani@gmail.com)
Date:Mar 22, 2007 8:38:55 am
List:org.xwiki.users
Attachments:
attachment-0001.htm - 4k

Hello all,

When I came back to write the steps, I found this page http://www.xwiki.org/xwiki/bin/view/AdminGuide/Encoding. The suggestions in the page is exactly correct. The other thing I can't say is that you only need to add -Dfile.encoing=UTF-8 to configure java application server. If you use tomcat5.5 which do not has catalina.sh or start.bat. You have to run tomcat5.5.exe and add -Dfile.encoing=UTF-8 in the graphical user interfaces tomcat properties configure->java->option. See the attachment.

<?ik=a09830fb37&view=att&th=1117a4bae7722eab&attid=0.1>2007/3/22, Sergiu Dumitriu <sergiu.dumitriu at gmail.com>:

You're welcome. And don't mind the time, it's more important to rest well.

Sergiu

On 3/21/07, ning wang < daning106 at gmail.com> wrote:

Hi Sergiu,

I just know how to make roll-back work well with Chinese characters. I will post the steps later. But now I have to go sleep.

Thanks for all suggestions.

Sincerely, Wang Ning

2007/3/17, Sergiu Dumitriu <sergiu.dumitriu at gmail.com>:

The question marks mean that in the database the document is not stored well.

I just checked it, and the rollback does not work well. Let me debug this a little on my system.

On 3/16/07, ning wang <daning106 at gmail.com> wrote:

Yes, I do mean it. Roll-back an older version which contain Chinese characters from the history.

2007/3/16, Sergiu Dumitriu < sergiu.dumitriu at gmail.com >:

Ning, what do you want to say with "roll-back"? As in roll-back an older version from the history?