atom feed7 messages in org.apache.incubator.openmeetings-userRe: OM 2.1 and Oracle JRE version
FromSent OnAttachments
Manoel Campos da Silva FilhoJun 3, 2013 7:27 am 
Holger SchranzJun 3, 2013 7:31 am 
Maxim SolodovnikJun 3, 2013 8:06 am 
Holger SchranzJun 3, 2013 8:15 am 
Manoel Campos da Silva FilhoJun 6, 2013 7:06 pm 
Maxim SolodovnikJun 6, 2013 7:10 pm 
Maxim SolodovnikJun 6, 2013 7:46 pm 
Subject:Re: OM 2.1 and Oracle JRE version
From:Manoel Campos da Silva Filho (
Date:Jun 6, 2013 7:06:07 pm

Hello guys. After a long, long time trying to install OM 2.0 and 2.1 (several months trying), now I finally had success.

So, I want to report the problem with the installation. How I reported at previous email, I was getting a "java.lang.NullPointerException ..." error when trying to install OM by the web interface.

At openmeetings.log I got several "org.apache.openjpa.persistence.PersistenceException: The column index is out of range: 2, number of columns: 1" error messages.

I understood the error, but didn't know why. I was sure that I had the correct pre-requisites and was following the correct installation steps (I already had installed OM 2.0 at other linux server).

After several tries, I resolved to try the command line tool.

The tool shown me a different error message (at a sql command): "unterminated string".

I didn't see this error at any log using the web interface installation. So, I suspected what was wrong: the use of backslash at SQL commands on PostgreSQL 9.1, because the postgresql standard_conforming_strings parameter was setted to "off". I changed the parameter to "on" and set escape_string_warning to "off" and solved the problem.

Thank you all for the help :) I hope my story can help other users

On Mon, Jun 3, 2013 at 12:15 PM, Holger Schranz <>wrote:

Ups, sorry for my wrong answer :( ...

Best regards


Am 03.06.2013 17:06, schrieb Maxim Solodovnik:

JDK7 works as expected also you need to inspect openmeetings.log to find the root cause

On Mon, Jun 3, 2013 at 9:31 PM, Holger Schranz <>wrote:

Hello Manoel,

OM 2.1 require JRE 1.6.

Best regards


Am 03.06.2013 16:28, schrieb Manoel Campos da Silva Filho:

Hello, I'm trying to install OM 2.1 and I'm receiving the error below when I open http://myserver:5080/openmeetings/install

Does OM 2.1 require Oracle JRE 1.6 ou 1.7? At error page, I see that it uses Tomcat 7.

java.lang.NullPointerException javax.servlet.http.HttpServlet.service( javax.servlet.http.HttpServlet.service(

org.red5.logging.LoggerContextFilter.doFilter( note The full stack trace of the root cause is available in the Apache Tomcat/7.0.34 logs.

-- WBR Maxim aka solomax