atom feed15 messages in org.freedesktop.lists.xorgRe: Slow 2D with radeon KMS
FromSent OnAttachments
Damien MirJan 30, 2010 6:32 am 
Clemens EissererJan 30, 2010 10:07 am 
Dave AirlieJan 30, 2010 11:51 am 
Nikos ChantziarasJan 30, 2010 11:53 am 
Clemens EissererJan 30, 2010 1:44 pm 
Harald BraumannJan 31, 2010 4:54 am 
Damien MirFeb 12, 2010 5:52 am 
Pauli NieminenFeb 12, 2010 6:42 am 
Alex DeucherFeb 12, 2010 6:46 am 
Damien MirFeb 13, 2010 7:30 am 
Damien MirFeb 15, 2010 7:33 am 
Michel DänzerFeb 15, 2010 8:16 am 
Damien MirFeb 15, 2010 8:45 am 
Dennis J.Feb 15, 2010 5:42 pm 
Damien MirFeb 16, 2010 10:55 am 
Subject:Re: Slow 2D with radeon KMS
From:Damien Mir (mail@mirabel-sil.com)
Date:Feb 12, 2010 5:52:30 am
List:org.freedesktop.lists.xorg

Now with : - xserver 1.7.4 - 2.6.33rc7 with KMS - libdrm, mesa, xf86-video-ati from git 2D and 3D are back OK on an R700 (HD4650 mobility (M98))

However I see 2 performance issues : - glxgears tops at 1450fps (compared to ~2500fps without KMS) - GL vsync is broken, ie visual tearing especially at playing large videos (XV or OGL) with Kwin compositing enabled

Any thoughts on this ?

On Sat, 30 Jan 2010 15:35:44 +0100 (CET) "Damien Mir" <mail@mirabel-sil.com> wrote:

Hi,

I just tried KMS with "radeon" driver, and 2D seems notably slow. Widgets takes time to draw, scrolling in Dolphin or Firefox lags, as if some 2D acceleration was not working alright.

I use radeon KMS on an R600 (HD 3870) and all works really well. 2D as well as 3D (glxgear, tuxracer, nexuiz). Kernel is 2.6.32 and drm, mesa, xf86-video-ati are latest git HEAD. Maybe you need a newer version of the ati driver.