atom feed1 message in net.sourceforge.lists.courier-users[courier-users] courier-imap 1.6.1 no...
FromSent OnAttachments
Darren SpruellNov 18, 2002 10:52 am 
Subject:[courier-users] courier-imap 1.6.1 not building on OpenBSD 3.2
From:Darren Spruell (darr@sento.com)
Date:Nov 18, 2002 10:52:02 am
List:net.sourceforge.lists.courier-users

Greetz all,

Is anyone familiar with a workaround to help compile courier-imap 1.6.1 on OpenBSD 3.2? My system is throwing up the following error upon a make check or make install (Using gmake 3.79.1):

====================================================================== Making check in maildir gmake[1]: Entering directory `/home/sancho/courier-imap-1.6.1/maildir' Compiling autoresponse.c autoresponse.c:7: autoresponsequota.h: No such file or directory gmake[1]: *** [autoresponse.o] Error 1 gmake[1]: Leaving directory `/home/sancho/courier-imap-1.6.1/maildir' gmake: *** [check-recursive] Error 1 ======================================================================

The only needed dependency I saw was gdbm; this is version 1.8.0.

I have tried running autoconf on the freshly extracted source (autoconf-2.52) and automake-1.4-p6 (dies with error) prior to running configure (full command = ./configure --prefix=/usr/local/courier-imap --without-ipv6 ) but no help. As I understand, these are unneccesary steps, correct?

Incidentally, the same error occurs on Red Hat 7.3 on another system I tried this on. Perhaps I am missing another dependency or some build/compile step?