atom feed43 messages in info.mailscanner.lists.mailscannerSpamassassin Timeout issue.
FromSent OnAttachments
Swati MeghanandSep 10, 2008 9:54 am 
Martin.HepworthSep 10, 2008 10:10 am 
Alex Neuman van der HansSep 10, 2008 2:51 pm 
Swati MeghanandSep 10, 2008 3:05 pm 
Alex Neuman van der HansSep 10, 2008 3:21 pm 
Marcello AnderliniSep 10, 2008 3:59 pm 
Alex Neuman van der HansSep 10, 2008 4:17 pm 
Randal, PhilSep 10, 2008 4:29 pm 
Marcello AnderliniSep 10, 2008 4:39 pm 
Marcello AnderliniSep 10, 2008 4:40 pm 
Randal, PhilSep 10, 2008 4:58 pm 
Alex Neuman van der HansSep 10, 2008 4:59 pm 
Chris SweeneySep 10, 2008 5:02 pm 
Alex Neuman van der HansSep 10, 2008 5:18 pm 
Kevin MillerSep 10, 2008 6:28 pm 
Chris SweeneySep 10, 2008 6:41 pm 
Alex Neuman van der HansSep 10, 2008 6:51 pm 
Martin.HepworthSep 10, 2008 6:52 pm 
Alex Neuman van der HansSep 10, 2008 7:09 pm 
Kevin MillerSep 10, 2008 7:35 pm 
Charles LacroixSep 10, 2008 7:39 pm 
Alex NeumanSep 10, 2008 8:09 pm 
Hugo van der KooijSep 10, 2008 9:15 pm 
Alex NeumanSep 10, 2008 9:34 pm 
Andrew MacLachlanSep 10, 2008 10:48 pm 
Scott SilvaSep 10, 2008 10:52 pm 
Drew MarshallSep 10, 2008 11:04 pm 
Scott SilvaSep 10, 2008 11:09 pm 
Andrew MacLachlanSep 10, 2008 11:12 pm 
Alex Neuman van der HansSep 10, 2008 11:17 pm 
Andrew MacLachlanSep 10, 2008 11:26 pm 
Scott SilvaSep 11, 2008 12:03 am 
Scott SilvaSep 11, 2008 12:09 am 
Andrew MacLachlanSep 11, 2008 12:24 am 
Scott SilvaSep 11, 2008 12:30 am 
Andrew MacLachlanSep 11, 2008 12:36 am 
Christopher J. BuckleySep 11, 2008 1:49 am 
ramSep 11, 2008 7:00 am 
Swati MeghanandSep 12, 2008 10:03 am 
ramSep 12, 2008 10:24 am 
Alex Neuman van der HansSep 12, 2008 1:15 pm 
Koopmann, Jan-PeterSep 15, 2008 10:05 pm 
Swati MeghanandSep 16, 2008 11:06 am 
Subject:Spamassassin Timeout issue.
From:Swati Meghanand (swat@gmail.com)
Date:Sep 12, 2008 10:03:35 am
List:info.mailscanner.lists.mailscanner

hi ram,

Thanks for ur help, running spamassassin in debugging mode helped me a lot.

I figured out that its not DNS related issue as spamassassin -D -t /path/to/mail gave me.

[2646] dbg: dns: name server: xxx.xxx.xxx.xxx, family: 2, ipv6: 0 [2646] dbg: dns: testing resolver nameservers: xxx.xxx.xxx.xxx, xxx.xxx.xxx.xxx [2646] dbg: dns: trying (3) xxx.xxx... [2646] dbg: dns: looking up NS for 'xxx.xxx' [2646] dbg: dns: NS lookup of xxx.xxx using xxx.xxx.xxx.xxx succeeded => DNS available (set dns_available to override) [2646] dbg: dns: is DNS available? 1

possibly not even RAZOR issue

[2646] dbg: razor2: part=0 engine=4 contested=0 confidence=0 [2646] dbg: razor2: results: spam? 0 [2646] dbg: razor2: results: engine 8, highest cf score: 0 [2646] dbg: razor2: results: engine 4, highest cf score: 0

yes i got some trouble with Pyzor, but not always

sometimes i get following errors

[17573] dbg: util: executable for pyzor was found at /usr/bin/pyzor [17573] dbg: pyzor: pyzor is available: /usr/bin/pyzor [17573] dbg: info: entering helper-app run mode [17573] dbg: pyzor: opening pipe: /usr/bin/pyzor check < /tmp/.spamassassin17573LkAPartmp [17778] dbg: util: setuid: ruid=0 euid=0 [17573] dbg: pyzor: [17778] finished: exit=0x0100 [17573] dbg: pyzor: got response: Traceback (most recent call last):\n File "/usr/bin/pyzor", line 4, in ?\n pyzor.client.run()\n File "/usr/lib/python2.3/site-packages/pyzor/client.py", line 934, in run\n ExecCall().run()\n File "/usr/lib/python2.3/site-packages/pyzor/client.py", line 188, in run\n if not apply(dispatch, (self, args)):\n File "/usr/lib/python2.3/site-packages/pyzor/client.py", line 264, in check\n response = runner.run(server, (digest, server))\n File "/usr/lib/python2.3/site-packages/pyzor/client.py", line 725, in run\n response = apply(self.routine, varargs, kwargs)\n File "/usr/lib/python2.3/site-packages/pyzor/client.py", line 57, in check\n msg = CheckRequest(digest)\n File "/usr/lib/python2.3/site-packages/pyzor/__init__.py", line 381, in __init__\n typecheck(digest, str)\n File "/usr/lib/python2.3/site-packages/pyzor/__init__.py", line 494, in typecheck\n raise TypeError\nTypeError [17573] dbg: info: leaving helper-app run mode [17573] warn: pyzor: check failed: internal error

still not able to finget out the exact reason since this error is not coming always...

Regards,

2008/9/11 ram <ra@netcore.co.in>

On Wed, 2008-09-10 at 14:24 +0530, Swati Meghanand wrote:

Hi,

I'm using mailscanner on a busy mail gateways from serveral months, which was working fine so far.From last few days I noticed incresed no of spam mails as well log Filtering queues (ofcourse slow processing of mailscanner).In log file of mailscanner I found following lines,

Sep 10 04:47:29 localhost MailScanner[11027]: Virus and Content Scanning: Starting Sep 10 04:47:37 localhost MailScanner[8400]: SpamAssassin timed out and was killed, failure 8 of 20 Sep 10 04:47:37 localhost MailScanner[8680]: SpamAssassin timed out and was killed, failure 14 of 20 Sep 10 04:47:38 localhost MailScanner[8680]: Message 1KdL6x-0005q5-L3 from xx.xx.xx.xx (xxx@xxx.x) to xxx.xx is not spam, SpamAssassin (not cached, timed out) Sep 10 04:47:38 localhost MailScanner[8400]: Message 1KdLDG-0006se-Ox from xx.xx.xx.xx (xx@xx.xxx) to xxx.xx is not spam, SpamAssassin (not cached, timed out)

it clealy indicates mailscanner is not (able to) scanning messages.

Hi Swati, MailScanner Spamassassin timing out can be due to multiple reasons most likely this is a DNS issue like others have said. It could also be a huge BAYES file or a blocked RAZOR port etc

Just check if your SA is still quering all the Dead DNS lists ( secuirtysage , ORDB , OPM BLITZED , DOB etc )

I would suggest take any mail and run spamassassin -D -t < /path/mail (test with a mail with multiple urls and one that has passed thru different mail hops )

That test would most probably give you enough results to find what is taking time.