atom feed12 messages in com.redhat.epel-devel-list[EPEL-devel] Re: nodejs broken
FromSent OnAttachments
Richard GraingerAug 23, 2017 1:55 am 
Anssi JohanssonAug 23, 2017 3:31 am 
Anssi JohanssonAug 23, 2017 4:13 am 
Richard GraingerAug 23, 2017 4:16 am 
Stephen GallagherAug 23, 2017 6:43 am 
Peter RobinsonAug 23, 2017 7:01 am 
Stephen John SmoogenAug 23, 2017 8:38 am 
Stephen GallagherAug 23, 2017 8:52 am 
Peter RobinsonAug 23, 2017 8:58 am 
Peter RobinsonAug 23, 2017 9:01 am 
Stephen GallagherAug 23, 2017 10:27 am 
Paul HowarthAug 24, 2017 1:09 am 
Subject:[EPEL-devel] Re: nodejs broken
From:Richard Grainger (grai@gmail.com)
Date:Aug 23, 2017 4:16:41 am
List:com.redhat.epel-devel-list

OK, thanks,

On Wed, Aug 23, 2017 at 12:13 PM, Anssi Johansson <ep@miuku.net> wrote:

Anssi Johansson kirjoitti 23.8.2017 klo 13.31:

Richard Grainger kirjoitti 23.8.2017 klo 11.55:

yum install nodejs

Try with this:

yum install nodejs --enablerepo=epel-testing

This will install nodejs with http-parser bundled in. http-parser was removed from EPEL because it is now in RHEL 7.4, and EPEL does not ship packages that are also in RHEL. http-parser will be in CentOS 7.4 once it is released.

I forgot to mention that this is only a temporary workaround. Once CentOS 7.4 is released, nodejs will revert back to depending on http-parser from RHEL/CentOS.