atom feed18 messages in com.googlegroups.recaptchaRe: Input Error: Invalid Referer
FromSent OnAttachments
ewal...@allen-kopet.comJul 20, 2010 12:42 pm 
P JHJul 20, 2010 12:49 pm 
ewal...@allen-kopet.comJul 20, 2010 1:05 pm 
craiggersJul 20, 2010 3:03 pm 
craiggersJul 20, 2010 3:23 pm 
reCAPTCHA SupportJul 20, 2010 6:34 pm 
jes5eJul 26, 2010 9:01 am 
aspineuxJul 26, 2010 5:53 pm 
John SwaringenJul 26, 2010 9:37 pm 
aspineuxJul 28, 2010 8:32 am 
ctae...@me.comJul 29, 2010 1:38 am 
TheTubMar 5, 2011 3:28 am 
WapplesApr 4, 2011 10:07 am 
WapplesApr 4, 2011 10:13 am 
John KorApr 15, 2011 1:10 am 
Michael HaMay 24, 2011 3:18 pm 
nuryanto doangOct 22, 2012 7:25 pm 
lindaOct 30, 2012 4:01 am 
Subject:Re: Input Error: Invalid Referer
From:reCAPTCHA Support ("sup@recaptcha.net)
Date:Jul 20, 2010 6:34:50 pm
List:com.googlegroups.recaptcha

Hi,

We are taking a look at this and believe we should have a fix for this issue by tomorrow, or Thursday at the latest. I'll post again when the fix is deployed.

Best, Colin

On Tue, Jul 20, 2010 at 6:23 PM, craiggers <cko@gmail.com> wrote:

When I view the html source code for the page, I found the following code:

<script type="text/javascript" src="http://api.recaptcha.net/challenge? k=6LcB47oSAAAAACB4ldZjQraw1-OYI2tDbfF-bEoQ">

Clicking on the serc, I get the following output:

document.write('Input error: Invalid referer');

If I then refresh the page (http://api.recaptcha.net/challenge? k=6LcB47oSAAAAACB4ldZjQraw1-OYI2tDbfF-bEoQ), I get:

var RecaptchaState = {    site : '6LcB47oSAAAAACB4ldZjQraw1-OYI2tDbfF-bEoQ',    challenge : '03AHJ_VuukH8jD9IiSfYmutlzCcR0UK632BGW7LLykU5KIx9- ik7gKtHNkz_WxM6Rsx9692wwL6_1IePGtZy1VUIQ4rkR_mXbZLEGhkmG_jUj_- KVf6mUZd0E9Y0tIegTR9kPAwjNX3LeE8YEuUyjAbou_XoJqFPhIoQ',    is_incorrect : false,    programming_error : '',    error_message : '',    server : 'http://www.google.com/recaptcha/api/',    timeout : 18000 };

document.write('<scr'+'ipt type="text/javascript" s'+'rc="' + RecaptchaState.server + 'js/recaptcha.js"></scr'+'ipt>');

It's very odd though. This is happening on a production server (outside of our control unfortunately), however on our staging server (a server in our building), it's not happening. I'm emailing our client to make sure the keys are correct now.

This is the first time I've used this forum, so please forgive me if this is somehow getting posted twice. I thought I posted this message, but don't see it anywhere.

We are also getting this problem. It started happening today. We need to get this fixed. If it makes any difference, the page this is happening in is in an iframe. Both the page, and the iframe page, are under the same domain.

Thanks,

Craig

On Jul 20, 3:05 pm, "ewal@allen-kopet.com" <ewall...@allen-

kopet.com> wrote:

I have double checked my key and it is correct.  What doesn't make sense is that it was working up until a couple days ago.

On Jul 20, 3:49 pm, P JH <paul@gmail.com> wrote:

<http://groups.google.com/group/recaptcha/browse_thread/thread/87e7523...> would indicate that you need to make sure you're using the correct key for your site.

On Tue, Jul 20, 2010 at 8:42 PM, ewal@allen-kopet.com

<ewal@allen-kopet.com> wrote:

I've had reCAPTCHA working on my site for about two months.  I noticed today that I was receiving an error message where the reCAPTCHA should appear and that error message is "Input Error: Invalid Referrer".  Can someone help me resolve this issue, I have looked the internet over and still haven't found a solution.  I have re-downloaded reCAPTCHA from their website and it still doesn't work.  I'm using PHP for my website.

-- PJH