atom feed12 messages in org.blender.bf-committersRe: [Bf-committers] UTF8 text input s...
FromSent OnAttachments
Brecht Van LommelNov 1, 2011 4:58 pm 
Campbell BartonNov 1, 2011 6:34 pm 
Alexandr KuznetsovNov 1, 2011 7:08 pm 
Campbell BartonNov 1, 2011 9:26 pm 
Jens VerwiebeNov 2, 2011 12:57 am 
Campbell BartonNov 2, 2011 2:40 am 
Jens VerwiebeNov 2, 2011 3:41 am 
Campbell BartonNov 2, 2011 3:56 am 
Jens VerwiebeNov 2, 2011 4:08 am 
KnappNov 2, 2011 4:10 am 
Jens VerwiebeNov 2, 2011 4:11 am 
Dalai FelintoNov 18, 2011 5:09 pm 
Subject:Re: [Bf-committers] UTF8 text input status (on OS X)
From:Jens Verwiebe (in@jensverwiebe.de)
Date:Nov 2, 2011 4:08:36 am
List:org.blender.bf-committers

Right, in the stamping result, the öäüÖÄÜ shows fine now, but still not in the textfield.

Jens

Am 02.11.2011 um 11:56 schrieb Campbell Barton:

Strange this fails for you,

I've uploaded the blend file which works when stamping the rendered image (because of the different font), but only displays correctly in the UI for me with the patch applied.

http://www.graphicall.org/ftp/ideasman42/unicode_stamp.blend

On Wed, Nov 2, 2011 at 9:42 PM, Jens Verwiebe <in@jensverwiebe.de> wrote:

I tested the patch but it changed nothing for me on OSX.

BTW: pasting ÖÄÜ from a texteditor worked also before, so still unsure about the real background of the problem.

Am 02.11.2011 um 10:40 schrieb Campbell Barton:

On Wed, Nov 2, 2011 at 6:57 PM, Jens Verwiebe <in@jensverwiebe.de> wrote:

Hi

I followed your conversation and also contatcted Damien ( original GHOST_cocoa
writer ) for send us a helping hand. I must say i also don´t think this is especially an OSX issue now, due i never
had any problems handling unicode in OSX else. Must be a special case in Blender.

Also all debug prints show up right outputs in several places. Again i like to point out that for example "öäüÖÄÜ" is only shown wrong in outliner ( "öäüOAU") but when exported to an external script ( luxblend here ), pby output was right sending it as "öäüÖÄÜ".

I formerly got some misinformation on the state of usability in other OS, so
this seems a more general problem.

Thus i don´t see atm a needed change for OSX in GHOST rather than checking
outliner and perhaps other modules.

Double checked and quite sure this is a font issue only, you can check this by replacing blenders normal font with the mono font and "öäüÖÄÜ" display correctly in the text button view. patch for testing: http://www.pasteall.org/25991/diff

note: to get the text into blender I had to save the text to a utf8 encoded file, load the text in blenders text editor, then paste into a text button field, copying directly from firefox gives invalid utf8 chars, but this shouldn't be an issue as long as input is utf8.