atom feed2 messages in org.mozilla.lists.dev-web-developmentOnly parts of image clickable in Firefox
FromSent OnAttachments
Daniel HofverbergAug 16, 2006 2:21 am 
SanderAug 16, 2006 3:17 am 
Subject:Only parts of image clickable in Firefox
From:Daniel Hofverberg (dani@telia.com)
Date:Aug 16, 2006 2:21:31 am
List:org.mozilla.lists.dev-web-development

I am having a weird problem on a page I'm designing/developing for a client of mine. For some strange reason, in a clickable image (made using regular A and IMG tags) on the site, only the upper part of the image seem to be clickable in Firefox/Mozilla. Everything works fine in Internet Explorer and Opera, at least the versions I've checked.

As the site is password-protected and developed with PHP/MySQL, I have made a copy of one page of the site as a pure HTML file. You can find it at: https://db.ocn.se/testsida.htm (don't forget the https, as it is an SSL site)

The CSS style sheet used on this page can be found at: https://db.ocn.se/main.css

On the page above, try to click on the small white Home icon at the upper left corner (just below the logo). In IE and Opera, the entire image is made into a link with this code. But on Firefox - at least the versions I've tried - only about the upper half of that icon is clickable, and the lower part is dead (even though the entire image is made into a link with a regular A tag).

Does anyone have any ideas why this doesn't work correctly in Firefox, or what to do to get it to work?

I have not been able to reproduce this problem with a simplier page - only with this page in this particular design/layout. But I assume there must be a reason for this weird behavior...

I appreciate any help anyone can provide.