using my loader patch the naming of the loader function would be
irrelevant since it's just including in a chain of loader functions,
starting with the classic (now called sys_loader_lib_internal) PD loader.
so this basically means, we could write an external that provides the
character escaping loader (and would not have to patch pd-core)
Concerning the setup function naming - how about xyz_altsetup ?
it's true that it should be distinguished from the old naming, but
should not have a prefix that excludes some object names.
again the problem with this is, that the current escaping does (for
"readability" replace "invalid" characters by "0x??" where "??" is the
hex-value of the character. starting a function-name with numbers is
generally a bad idea, if you want a compiler to read it.
so that's why we thought of a prefix that guarantees a valid indentifier.
prefixing "setup_" (which i still think is nice ,-)) would solve both
the problem with valid id's and establish a distinct naming scheme
(which, as hans pointed out, could also be seen as a problem)