atom feed22 messages in org.opensolaris.zfs-discuss[zfs-discuss] zfs corruption w/ sil31...
FromSent OnAttachments
Ed SaipetchOct 29, 2007 9:09 pm 
Nathan KroenertOct 29, 2007 9:22 pm 
Neal PollackOct 29, 2007 9:24 pm 
Edward SaipetchOct 29, 2007 10:00 pm 
MCOct 29, 2007 10:28 pm 
Will MurnaneOct 29, 2007 10:29 pm 
James C. McPhersonOct 29, 2007 10:30 pm 
Neal PollackOct 29, 2007 10:42 pm 
Nigel SmithOct 30, 2007 3:15 am 
Nigel SmithOct 30, 2007 3:25 am 
Tomasz TorczOct 30, 2007 4:35 am 
Stephen UsherOct 30, 2007 5:10 am 
Fran...@Sun.COMOct 30, 2007 5:16 am 
Ed SaipetchOct 30, 2007 7:07 am 
Al HopperOct 30, 2007 7:28 am 
Ed SaipetchOct 30, 2007 7:32 am 
Mauro MozzarelliOct 30, 2007 8:33 am 
Nigel SmithOct 31, 2007 5:54 am 
Edward SaipetchOct 31, 2007 6:08 am 
Mario GoebbelsOct 31, 2007 6:13 am 
Edward SaipetchOct 31, 2007 6:24 am 
grant beattieNov 4, 2007 2:10 am 
Subject:[zfs-discuss] zfs corruption w/ sil3114 sata controllers
From:grant beattie (gra@grunta.com)
Date:Nov 4, 2007 2:10:43 am
List:org.opensolaris.zfs-discuss

Ed Saipetch wrote:

To answer a number of questions:

Regarding different controllers, I've tried 2 Syba Sil 3114 controllers
purchased about 4 months apart. I've tried 5.4.3 firmware with one and 5.4.13
with another. Maybe Syba makes crappy Sil 3114 cards but it's the same one that
someone on blogs.sun.com used with success. I had weird problems flashing the
first card I got, hence the order of another one. I'm not sure how I could get
2 different controllers 4 months apart and then use them in 2 completely
different computers and both controllers be bad.

another data point..

I run two SiI 3114 based cards in my home fileserver running s10u3. I was having ZFS data corruption issues and I suspected the SiI cards - that was until I replaced the motherboard/CPU/memory. I didn't have the time or patience to try to determine which component was at fault, but I swapped the motherboard/CPU/memory and stressed it for a few hours and the data corruption problem was gone.

before that, I was seeing data corruption issues within minutes. maybe it was just memory, but I'll never know. I junked the old kit after I confirmed I had eliminated the problem.

grant.