atom feed44 messages in com.xensource.lists.xen-usersRe: [Xen-users] Installing a Debian E...
FromSent OnAttachments
ThomasJun 22, 2008 7:04 am 
jim burnsJun 22, 2008 7:41 am 
ThomasJun 22, 2008 8:02 am 
ThomasJun 22, 2008 8:58 am 
ThomasJun 22, 2008 9:19 am 
Daniel HeemannJun 22, 2008 9:32 am 
ThomasJun 22, 2008 9:38 am 
Dion KantJun 22, 2008 9:45 am 
ThomasJun 22, 2008 10:06 am 
ThomasJun 22, 2008 10:16 am 
ThomasJun 22, 2008 10:23 am 
jim burnsJun 22, 2008 11:29 am 
Dion KantJun 22, 2008 11:33 am 
Bastian BlankJun 22, 2008 12:12 pm 
ThomasJun 22, 2008 12:39 pm 
Daniel HeemannJun 23, 2008 4:11 am 
ThomasJul 19, 2008 12:09 am 
netz-haut - stephan seitzJul 19, 2008 12:41 am 
ThomasJul 19, 2008 1:26 am 
Thomas HagerJul 19, 2008 3:17 am 
ThomasJul 19, 2008 5:14 am 
Thomas HagerJul 19, 2008 6:49 am 
ThomasJul 19, 2008 10:57 am 
Thomas HagerJul 20, 2008 2:34 am 
ThomasJul 20, 2008 6:58 am 
Thomas HagerJul 20, 2008 2:38 pm 
ThomasJul 21, 2008 3:38 am 
Thomas HagerJul 22, 2008 11:57 am 
ThomasJul 22, 2008 12:54 pm 
Thomas HagerJul 24, 2008 5:27 am 
ThomasAug 18, 2008 2:13 pm 
Thomas HagerAug 18, 2008 11:58 pm 
ThomasAug 19, 2008 12:15 am 
ThomasAug 31, 2008 6:44 am 
Todd DeshaneAug 31, 2008 6:53 am 
ThomasAug 31, 2008 7:08 am 
Todd DeshaneAug 31, 2008 7:26 am 
ThomasAug 31, 2008 7:39 am 
Tim PostAug 31, 2008 9:13 am 
ThomasSep 1, 2008 3:17 am 
Todd DeshaneSep 1, 2008 8:53 am 
ThomasSep 1, 2008 9:33 am 
Todd DeshaneSep 1, 2008 9:37 am 
ThomasSep 1, 2008 10:41 am 
Subject:Re: [Xen-users] Installing a Debian Etch DomU using debootstrap
From:Thomas Hager (du@sigsegv.at)
Date:Jul 20, 2008 2:38:38 pm
List:com.xensource.lists.xen-users

On Sun, 2008-07-20 at 15:58 +0200, Thomas wrote:

Registering block device major 3 hda: unknown partition table hdb: unknown partition table

at least xen sees the discs now.

I am pretty sure, that /dev/hda1 and /dev/hda2 must be used in Xen.

no, i really don't think so.

i tested the debootstrap procedure on my xen server and it works fine.

i did:

- create a logical volume with 10G - create an ext3 fs on this lv - mount the lv somewhere (/mnt/loop in my case) - debootstrap the new lv with: debootstrap lenny /mnt/loop \ ftp://ftp.at.debian.org/debian/ - mount /proc to /mnt/loop/proc, chroot into /mnt/loop and run dselect to install the rest of the required software - exit chroot, unmount /mnt/loop/proc - rsync -a /lib/modules/2.6.18-6-xen-amd64 /mnt/loop/lib/modules/ - unmount /mnt/loop

i booted this domU with the following config:

kernel = "/boot/vmlinuz-2.6.18-6-xen-amd64" ramdisk = "/boot/initrd.img-2.6.18-6-xen-amd64" builder='linux' memory = 256 name = "centauri" vcpus = 1 vif = [ 'mac=00:16:3e:14:07:88, bridge=xenlan' ] disk = [ 'phy:/dev/babylon/xen_test,hda,w' ] hostname="centauri" root = "/dev/hda ro" extra = "3 noirqdebug"

on_poweroff = 'destroy' on_reboot = 'restart' on_crash = 'restart'

everything went fine, the domu successfully booted into runlevel 3.

maybe you should give the netinstall method a try?

kr, tom.