atom feed72 messages in org.w3.public-webapiRe: ACTION-87: Selectors API
FromSent OnAttachments
45 earlier messages
Anne van KesterenMay 13, 2006 4:15 am 
lioreanMay 13, 2006 12:08 pm 
Anne van KesterenMay 13, 2006 12:26 pm 
lioreanMay 13, 2006 2:40 pm 
Anne van KesterenMay 14, 2006 7:20 am 
lioreanMay 14, 2006 4:22 pm 
Anne van KesterenMay 15, 2006 3:15 am 
lioreanMay 16, 2006 9:29 pm 
Anne van KesterenMay 17, 2006 5:18 am 
Lachlan HuntMay 17, 2006 6:19 am 
Anne van KesterenMay 17, 2006 6:30 am 
Jim LeyMay 17, 2006 6:35 am 
Lachlan HuntMay 17, 2006 7:02 am 
Robin BerjonMay 17, 2006 7:07 am 
Anne van KesterenMay 18, 2006 12:46 am 
Jonas SickingMay 30, 2006 3:11 pm 
Jonas SickingMay 30, 2006 3:24 pm 
Jonas SickingMay 30, 2006 3:42 pm 
Ian HicksonMay 30, 2006 3:55 pm 
Robin BerjonMay 30, 2006 4:15 pm 
Jonas SickingMay 30, 2006 5:56 pm 
Anne van KesterenJun 5, 2006 2:46 am 
Anne van KesterenJun 5, 2006 2:49 am 
Jonas SickingJun 5, 2006 12:31 pm 
Charles McCathieNevileJun 5, 2006 5:37 pm 
lioreanJun 5, 2006 6:16 pm 
Maciej StachowiakJun 5, 2006 10:40 pm 
Subject:Re: ACTION-87: Selectors API
From:Charles McCathieNevile (cha@opera.com)
Date:Jun 5, 2006 5:37:03 pm
List:org.w3.public-webapi

On Mon, 05 Jun 2006 19:49:36 +1000, Anne van Kesteren <ann@opera.com> wrote:

On Wed, 31 May 2006 00:11:23 +0200, Jonas Sicking <jon@sicking.cc>

I'm not in love with having "match" in the name, but I could live with matchAll() and matchOne().

I like these names. Having short names is nice and all, but having clear ones is even better. Especially when the extra cost is just another three letters to type.

I'm not really fond of matchOne()... Is there any precedence on this?

There is a precedent for any naming thing you care to consider, and some you would prefer not to.

I am with Jonas on this - I don't think the name hurts or increases confusion and it does slightly decrease it. But picking names is always painful. We'll never get it perfectly right, but we can always get it oh-so-very wrong :(

cheers

chaals