atom feed3 messages in org.netbeans.web.issues[Issue 169986] org.apache.jasper.Jas...
FromSent OnAttachments
pjir...@netbeans.orgAug 11, 2009 5:35 am 
cyhe...@netbeans.orgAug 11, 2009 8:25 am 
casc...@netbeans.orgAug 12, 2009 1:37 am 
Subject:[Issue 169986] org.apache.jasper.JasperException: The absolute uri: [...] cannot be resolved in either web.xml or the jar files deployed with this application
From:cyhe...@netbeans.org (cyhe@netbeans.org)
Date:Aug 11, 2009 8:25:53 am
List:org.netbeans.web.issues

http://www.netbeans.org/issues/show_bug.cgi?id=169986

------- Additional comments from cyhe@netbeans.org Tue Aug 11 15:26:36 +0000
2009 ------- Reproduced, it indeed doesn't compile - the reason is that NB 6.5.1 uses Struts
1.2.9 and NB 6.7 Uses Struts 1.3.8. The workaround is relatively easy - just replace 1.3.8 libraries with 1.2.9 and
it will work again.

The alternative may be to use the 1.3.8 library but than your .jsp must be
changed to accomodate the change which might be complicated - try replacing at least

<%@ taglib uri="http://jakarta.apache.org/struts/tags-bean" prefix="bean" %> <%@ taglib uri="http://jakarta.apache.org/struts/tags-html" prefix="html" %> <%@ taglib uri="http://jakarta.apache.org/struts/tags-logic" prefix="logic" %>

<html:html locale="true">

in your .jsp with

<%@ taglib uri="http://struts.apache.org/tags-bean" prefix="bean" %> <%@ taglib uri="http://struts.apache.org/tags-html" prefix="html" %> <%@ taglib uri="http://struts.apache.org/tags-logic" prefix="logic" %>

<html:html lang="true">

does this work for you?